Jump to content


Photo
- - - - -
Completed

Whitelist discrepencies between au.serveme.tf and ozfortress server lobbies

Pending Dev response

  • Please log in to reply
8 replies to this topic

#1 Nobel_H

Nobel_H

    Advanced Member

  • Users
  • PipPipPip
  • 85 posts

Posted 27 April 2016 - 09:04 AM

TF2C Profile: Nobel H
Region: AU

Browser: Google Chrome
Critical plugins: --
OS: Windows
Connection type: --

Bug type: In-game
Lobby ID: --
Date & Time: --

When an ozfortress server is used to create a lobby, the ozf15 whitelist is loaded fine.

When a booked server from au.serveme.tf is used to create a lobby, the whitelist loaded is an extremely antiquated whitelist. Quickiebomb launcher, Iron Bomber, skins, newer cosmetic items, etc are not allowed.

This occurs regardless of whether the whitelist is set to "league whitelist" or "default whitelist". One way to load the correct whitelist is to force it via the "custom whitelist" option, however this requires the server be unbooked and rebooked when switching between different game modes.

The ozf15 configs are on both servers. Typing "rcon exec ozfortress_6v6_5cp" into console on both servers results in the ozf15 whitelist loading correctly.

However, when a lobby is created, the au.serveme.tf servers end up with the antiquated whitelist.

If the same scenario is done with an ozfortress server, the ozf15 whitelist loads correctly.



#2 nrd.

nrd.

    Former TF2C Staff

  • Members
  • PipPipPipPipPip
  • 2105 posts
  • LocationSydney, Australia

Steam Profile


           

Posted 27 April 2016 - 12:02 PM

I actually want to find the solution for this as well.


It's been fun, thanks for the ride.


#3 obla

obla

    Former staff

  • Members
  • PipPipPip
  • 447 posts
  • LocationSydney

Steam Profile


   

Posted 27 April 2016 - 12:28 PM

That's because looking at what TF2Center executes currently, you will notice it is using:

mp_tournament_whitelist "cfg/whitelists/owl.txt"

 

Simple fix: 

mp_tournament_whitelist "cfg/ozfortress_whitelist_6v6.txt"
 
Explanation:
ozfortress moved to a more conventional and systematic way of executing configs. /whitelists/owl.txt was made redundant and ozfortress_whitelist_6v6.txt was implemented.

-poke-


#4 nrd.

nrd.

    Former TF2C Staff

  • Members
  • PipPipPipPipPip
  • 2105 posts
  • LocationSydney, Australia

Steam Profile


           

Posted 27 April 2016 - 12:40 PM

Cool, can we update this in what TF2C executes?

It's been fun, thanks for the ride.


#5 MasterNoob

MasterNoob

    Founder

  • Staff
  • 3719 posts

Posted 28 April 2016 - 05:13 PM

Changed 6v6 configs; what about HL?



#6 nrd.

nrd.

    Former TF2C Staff

  • Members
  • PipPipPipPipPip
  • 2105 posts
  • LocationSydney, Australia

Steam Profile


           

Posted 29 April 2016 - 12:14 AM

Thanks MN, HL uses UGC configs so it should be OK. Might have to update whitelists again in May for the new season.


It's been fun, thanks for the ride.


#7 Nobel_H

Nobel_H

    Advanced Member

  • Users
  • PipPipPip
  • 85 posts

Posted 29 April 2016 - 07:06 AM

Bumping this again. It would be helpful if you could somehow make the fields "ozfortress" for config and "Highlander" for Game Type to be mutually exclusive.

 

There have been many cases where inexperienced lobby leaders select ozfortress and Highlander, the end result is a messed up config and an incorrect whitelist. The correct configuration for HL lobbies is UGC and Highlander.

 

The ozfortress HL config is extremely outdated and the league itself no longer exists.



#8 MasterNoob

MasterNoob

    Founder

  • Staff
  • 3719 posts

Posted 02 May 2016 - 09:48 PM

We offer a certain flexibility when it comes to configs. We expect people to know what they're doing.



#9 nrd.

nrd.

    Former TF2C Staff

  • Members
  • PipPipPipPipPip
  • 2105 posts
  • LocationSydney, Australia

Steam Profile


           

Posted 03 May 2016 - 12:57 AM

This issue has been resolved. Marking as completed.


It's been fun, thanks for the ride.






Also tagged with one or more of these keywords: Completed, Pending Dev response

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users